Dashboard and API down

Incident Report for Incognia

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 21:11 UTC

Monitoring

A fix has been implemented and services are returning to operational.
Posted Jun 25, 2026 - 21:01 UTC

Update

We are continuing to investigate this issue.
Posted Jun 25, 2026 - 20:58 UTC

Investigating

Dashboard is down and API is returning 4xx and 5xx.

We are currently investigating the issue.
Posted Jun 25, 2026 - 20:58 UTC
This incident affected: Product dashboard (User Authentication, Investigation, Integration, Account and Organization, API Reference, Documentation, Configuration) and APIs (Global API).