Dashboard degraded performance - AWS Service Disruption

Incident Report for Incognia

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:14 UTC

Identified

We are investigating reports of increased latency and performance degradation across our services. This incident is related to a broader service disruption affecting Amazon Web Services (AWS). We are monitoring the situation closely and will provide further updates as we have more information on the resolution.
Posted Oct 20, 2025 - 16:55 UTC
This incident affected: Product dashboard (User Authentication, Explore, Integrations, Account and Organization, API Reference, Documentation).