AWS Outage

Incident Report for Incognia

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:27 UTC

Monitoring

Incognia’s systems (API & Dashboard) experienced degradation due to an AWS outage (see https://health.aws.amazon.com/health/status) from 07:00 UTC to 09:40 UTC.
Posted Oct 20, 2025 - 09:53 UTC
This incident affected: Product dashboard (User Authentication, Explore, Integrations, Account and Organization, API Reference) and APIs (Global API).